Can't use keyboard once game has loaded.

  • Can't use keyboard once game has loaded.

    My keyboard isn't working and cannot control my player or use my mouse to look around.
    ie: I can't use WASD,Space,Ctrl etc...

    I can load into the game fine.
    I can press `tilde key and type in console commands and can use the mouse to click things (ie: weather menu) and close menu's such as the "time" menu.
    I cannot press escape and check my options, the only way I can manage to press escape is by doing certain commands such as "connect", which then makes the screen go all grey.
    I tried to bind the keys but maybe they don't stay bound, I'm not sure. The only way to fix my game after doing that is to click restart map, which then puts me back in the same place I started.

    I have re-downloaded the game once and also have repaired the game.

    What I start with.


    How I end up bringing the menu options up.


  • My keyboard and mouse don't work at all in the normal user view, the only button I can push is ` to open the console, at that stage then my mouse can navigate the console and other debug windows and I can type and use keyboard etc.

    I can't get to the settings without messing the game up and they don't save so I can't even reload the game once I fix the keybindings. I can only use my keyboard for console commands. It's not working when I'm just trying to move the player.

    I have tried manually editing the input.cfg file but each button is just named like this.
    Display Spoiler

    Device (name = "Keyboard", type = 'KYBD')
    {
    Control (name = "1")
    {
    Action {unsigned_int32 {'cus1'}}
    }
    Control (name = "2")
    {
    Action {unsigned_int32 {'cus2'}}


    Have tried repairing the game, reinstalling the game. Nothing fixes it. Clearly my keyboard and mouse work in-game as they work for the console etc but just not for movement or gameplay.

  • I am still having this error in 0.0.9. All control settings are bound properly. Same issue.

    Cannot use any single key apart from the tilde key ` to open console and cannot use my mouse to look around.

    Once console is open I can use mouse/keyboard to use console commands etc and click on things. Once I type a command such as connect it goes to a grey screen and allows me to open the escape menu. I try restarting the game after that and still no luck.

    Anyone else?

    @masterbrain @Memphis any ideas what's going on here?

    The post was edited 1 time, last by mmmBetty ().

  • Hey well I'm not sure why it doesn't work foy you but you can try and apply my input.cfg to your savegame and see if that works.

    In the mean time I'll make a post that translates all the controls in the input.cfg file, so it's easier to edit it.

    Had to upload it in a zip because cfg files aren't allowed as attachements.
    Files
    • input.zip

      (613 Byte, downloaded 128 times, last: )

    i5 4690k - 3,5 Ghz, EVGA gtx 1070 ftw hybrid - 8 gb vram, 16 gb 1600 Mhz ddr3 ram
  • How is it in other games, or in windows? It's functional normaly I suppose.

    Probably this will be stupid ideas, but.
    - Have you tried to put your keyboard to other USB port?
    - what type of keyboard is set in Win - US, or other (it is just idea)
    - change keyboard for other one (something may be broken up)

    This is mystery. I've never met this problem before.


    CPU Type - Intel(R) Core(TM) i5-4460 CPU @ 3.20GHz
    GPU Type - Graphics Chipset AMD Radeon R9 280X 3,072 GB GDDR5
    GPU Driver - Radeon Software Version 17.12.1
    RAM - 8 GB
    Win 7 64bit
  • Okay, The problem is fixed now... I don't know how or why but I deleted and re-installed the game a third time and then it game me the option to make a profile and also start the mission once I entered the game.

    I never had that option before so I'm not sure what went wrong there but I can move around and stuff now.

    @Memphis @masterbrain The problem is gone with a third complete re-install.

    For anyone who comes with the same issue this is what I did.

    • Navigate to control panel, uninstall "Cattle and Crops" and also uninstall "Cattle and Crops Online Installer".
    • Navigate to C:\Users\YourPCNameHere\AppData\Roaming and delete the Launchpad folder.
    • Navigate to C:\Program Files (x86) and delete Cattle and Crops folder.
    • Navigate to C:\Users\YourPCNameHere\Documents\My Games and delete the Cattle and Crops folder.
    • Re-download the launcher, install that and re-download the game.
    • Success!