Spurhalteassistent (FGS) funktioniert nicht mit Lenkrad. Workaround: Achse "Stick" statt "Wheel" konfigurieren.

  • Ja, konnte es gerade reproduzieren!

    Steht die Definition der Lenkachse (Wheel axis) auf "Lenkrad" funktioniert das FGS nicht, stellt man es wieder auf die Standardeinstellung(Achse), funktioniert alles wie es soll.
    Danke @Blackwiper !

    Also einfach auf Standardeinstellung belassen und dort nicht rumfummeln.

    Ich schätze, dass dies noch geändert wird, da dies doch etwas irreführend ist.

    Allerdings wäre auch alles nach dem löschen der inputconfig erledigt gewesen, wohlmöglich wäre das auch auf einem Screenshot aufgefallen.
  • @Blackwiper

    Danke für Deine Tests. :thumbsup:

    Etwas irreführend ist es für mich allerdings schon, denn wenn man ein Lenkrad hat, dann würde ich als Tastatur Spieler, der sich da nicht auskennt, auch "Wheel" einstellen. Die Standard Config weiss aber scheinbar schon, was zu tun ist.

    @DannyA4
    Danke, dass Du es auch noch einmal reproduziert hast. Dann müssen wir gar nicht bis zur v1.0 warten. :thumbup:
  • @Blackwiper
    Danke dir.

    Noch eine Anmerkung, die Standard Konfiguration ist nicht immer das was funktioniert. Hier muss ich die Standard Konfiguration ändern, da der Controller sonst nicht nutzbar ist. forum.cattleandcrops.com/threa…h/?postID=51441#post51441
    Damit muss ich an der Konfiguration rumfummeln, weil die Standard Konfiguration nicht funktioniert. Vielleicht hätte die Lösung von dem genannten Problem, auch dieses hier verhindert.

    Die Frage ist was durch die Einstellung Lenkrad als Achse denn anders ist? Somit kann man das vielleicht beheben und es ist unrelevant was eingestellt ist. Das wäre am besten.
  • @Nachtfalke Sorry aber bei der Vorgeschichte hier im Thread, und speziell nachdem der Fehler gefunden wurde, dein weiteres nach treten, auch von anderen, mit Spitzen die aufgrund der Vorgeschichte an mich gehen, sind keine Basis auf der ich mit dir hier weiter über Fehlersuche diskutieren möchte.
    Allgemein lautet die Devise gegen mich seit den letzten Tagen anscheinend immer alle Posts zu sichern, vor allem die unbearbeitete Version, um diese dann im Falle des Falle, veröffentlichen zu können.

    In einem oft verlinkten Video von @JP86 zum Thema Lenkradeinstellungen, wird unter anderem auch erwähnt, dass man die Achse auf "Steering Wheel", also "Lenkrad", einstellen soll. @JP86 nur als Hinweis da dies nach den neuesten Erkenntnissen hier in Verbindung mit dem FGS für Probleme sorgt, daher wäre es gut wenn du dies anpassen würdest. Des Weiteren ist in den Screenshots im oben verlinkten Thread auch zu sehen, das dort die Achseneigenschaft auf Lenkrad steht. Das hat auch bisher immer funktioniert, und niemand hat bisher bemerkt das dies falsch ist, weder ein Entwickler oder sonst jemand hat dazu etwas gesagt. Deswegen und aufgrund der anderen Geschichte mit der falschen Achseigenschaft, habe ich nachdem ich alle Profile gelöscht habe, und ebenso das Spiel in der Launcher Version einmal als Test komplett neuinstalliert habe, beim Kalibrieren, dies immer auf Lenkrad umgestellt. Es war in dem Fall ein Fehler, welcher aber ja glücklicherweise gefunden wurde. Warum dann hier immer weiter Spitzen verteilt werden müssen, ist mir schleierhaft. Hätte man nach dem Melden des Fehlers direkt gemeldet dass es bei einem selber funktioniert, hätte sich MBB das besorgen des Lenkrads auch sparen können. Also sind hier wohl an mehreren Stellen "Fehler" passiert.

    Nach Umstellung auf "Normale Achse.." funktioniert es auch bei mir, ohne irgendetwas anderes zu ändern.
  • Hey ho,

    also zum Problem warum es nicht geht auf Wheel axis Lenkrad kann ich mir nur so erklären:

    (Wheel axis Lenkrad) Das Lenkrad hat 900grad in Vollbelegung ohne Deadzone und dadurch kann der Spurhalteassistent die Nullstellung nicht finden.

    (Wheel axis Normale Achse) Das Lenkrad hat von der Nullstellung nach links sowie nach rechts 450Grad und die Nullstellung ist gleich der Ausgangspunkt der Deadzone.


    Das wäre so meine Erklärung bin aber auch nur Leihe und kein Profi :D
  • @Blackwiper Ist eine Idee, jedoch funktioniert der Autopilot tadellos mit der Einstellung "Lenkrad", und der muss dafür auch die Nullstellung erkennen. Daher bin ich auch nicht auf die Idee gekommen das es, anscheinend nur für das FGS, ein Problem ist.

    Denke die Entwickler können über debug tools erkennen warum das ein Problem beim FGS ist. Denn das ist doch etwas suboptimal und eine unnötige Fehlerquelle. Wie man sieht hat es ja einige betroffen, daher werden es unter Umständen wieder mehr, wenn es neue Käufer gibt.
  • @newbienearcologne

    also dazu würde ich jetzt sagen der Autopilot fährt doch nur eine vorgeschrieben so wie gespeicherte Strecke. Wozu benötigt er da den Nullpunkt? Der Nullpunkt wenn er ihn benötig wurde doch schon beim aufzeichnen der Strecke vorgegeben. Also das war jetzt so mein denken aber wie du schon sagst die Jungs von MBB werden das schon machen. Wie viele hat es denn betroffen ist mir jetzt gar nicht so aufgefallen.
  • ScaniaWTW wrote:

    ...die Neugier hat mich wieder an den Rechner getrieben ^^

    Zum ersten funktioniert es nun auch bei mir ohne Neuinstallation...
    Zum zweiten hab ich nun 0.03 als Totzone eingestellt.
    Ich behelfe mir grade wie folgt:
    Die Tasten zum öffnen des Menüs und die Aktivierung sind auf einem Joystik belegt, die Taste für den Lenkbefehl hab ich mir ans Lenkrad gelegt. Wenn alles eingestellt ist benötigt man vorerst (wird sicher noch geändert) nur noch die Taste für den Lenkbefehl. Das GPS ist solang aktiv bis es mit der entsprechenden Taste wieder deaktiviert wird, man kann also entspannt am Vorgewende wenden und drückt dann die Taste für den Lenkbefehl (A, D oder eben wie bei mir die Taste am Lenkrad), Voraussetzung hierfür ist eben die Einhaltung der Totzone was hoffentlich noch auf 0 geändert wird im Laufe der Zeit....

    So aber kann ich mich erstmal gut mit anfreunden ^^

    Bis die Tage Jungs ^^
    Update,

    mit den Erkenntnissen von @Blackwiper hab ich gestern beim dreschen mal das ganze etwas ausgiebiger testen können ^^
    Nach der Umstellung der Achse hab ich alle benötigten Knöpfe nun am Lenkrad, einzige Ausnahme ist die Standardbelegung zum öffnen des Menüs.
    Die Totzone hab ich auch auf 0.01 runter genommen.
    Nachdem ich im FGS Menü alle Einstellungen erledigt hatte konnte ich mich quasi zurücklehnen. FGS anschalten, Vorgewende abarbeiten (das geht natürlich auch ohne das FGS vorher einzuschalten) und im Anschluss das FGS aktivieren für die langen Bahnen!
    Anfangs hab ich am Vorgewende das FGS wieder deaktiviert und nach dem einfahren in die neue Bahn wieder aktiviert!
    Das ist allerdings nicht nötig, es reicht nach dem einfahren das Lenkrad in die Totzone zu bewegen und kurz drauf aktiviert es sich wieder von allein(man darf es nur nich deaktivieren zum wenden)...tolle Sache, wusste garnicht das des auch so geht :whistling:

    ...so lässt sich's ackern :love:
    Scania WTW auf YouTube 《-------》 ScaniaWTW auf Twitch
    AMD Ryzen5 3600x | ASUS GeForce RTX 2070 SUPER DUAL EVO OC 8-GB | MSI MPG x570 Gaming Plus | 32-GB G.Skill DDR4-3200 DIMM CL | Logitech G27