Known Cattle and Crops Bugs And Their Fixes

  • Known Cattle and Crops Bugs And Their Fixes

    Thought it would be handy to have a bug megathread so @masterbrain and @Memphis could get a correlated view on bugs people are having.

    Remember it is the tech demo so bugs such as being able to access under the map etc probably shouldn't be reported really.

    This is more for gamebreaking bugs. Login errors, inability to launch the game, graphics errors etc.

    Would be best for the devs in your report to state your Operating system and Computer details. Basically give as much detail as possible.

    Template to use...



    mmmBetty wrote:

    Operating system:

    Computer hardware (ie: CPU, GPU, Anything relevant):

    Have you updated GPU drivers (yes/no):

    Description of bug:

    Is it reproducible:

    Any screenshots of bug:

    Client/Game Bugs

    IC cab control not working with left ctrl.1. Go to settings, controls, look for "release mouse" and click on the empty box and press your left control button, then apply, then save.
    Grey patch over half the screen.1. Update your GPU drivers
    2. Someone mentions changing resolutions in-game fixed the issue.
    3. Do a fresh install of GPU drivers.
    [Reference Image](imgur.com/a/1d1SL)
    Can't log into account in the launcher.1. Was mentioned by one user that they had symbols and numbers in their pass. Reverted to just letters and advised that it worked after that.
    Logitech G27 Steering wheel not working properly. Pedals back to front, other issues.Most likely joysticks/gamepads/steering wheels not supported yet.[Maybe Helpful Image](hostingpics.net/viewer.php?id=221290Croquis.png)
    Poor frame rates and low FPS especially with multiple screens.


    (Some multi screen users report no issues.)
    No Fix.
    Most likely optimization issues due to being a tech demo.
    Changing game settings restores the game to a window in the center of screen.1. Re-maximize the window.
    Game fails to launch.1. Unsure as of yet.
    2. Re-install launcher.
    [Reference Image](forum.cattleandcrops.com/attachment/112-fail-png/)
    Anti-Virus keeps blocking the install.1. Allow an exception in your anti-virus.
    2. Enter gaming mode in your anti-virus (if applicable).
    3. Disable anti-virus temporarily and install.
    4. Allow exceptions through windows firewall.
    Login screen in launcher messed up, using windows 10.1. Restart Launcher


    2. First textbox is for login ID and second for password.
    [Reference Image](Servertest)
    Installer won't open, keeps sending user to a site to download the GTK.1. Restart computer.
    Cannot revert in-game settings back to default.1. Go to X:\docs\my games\Cattle And Crops\Profiles\Name


    2. Delete input.cfg and reinstall.




    General Game Bugs



    Right hand tractor door won't close.No Fix[Reference Image](imgur.com/a/M459S)
    Using cab control to turn the tractor on then back off again breaks the game and you are unable start your tractor again.No Fix
    Cannot Complete MissionNo Fix
    If you hold down the X button (Unfold/fold) instead of just pressing it, cultivator glitches to folded position if folded down. If in the process of unfolding and you hold the X button it returns to folded position and then restarts the unfolding process.No Fix
    Cannot enter the tractor1. Pressing E only works on the left side of the tractor.

    The post was edited 10 times, last by mmmBetty ().

  • So, to make this as effective as possible do a good bugg repport not just " this don't work"

    *What is not working? (detailed description)
    *What did you do before the bugg apeard?
    *Have you manage to recreat the bugg, and if how?

    I'm no proffesional bugg writer but i guess this is some sort of start of how to repport in a good way.

    (If some one have a better template please post)
  • Having issues with graphics. grey pixelated cloud around the avatar

    System Information report written at: 06/09/17 14:26:04
    System Name: EIRE
    [System Summary]

    Item Value
    OS Name Microsoft Windows 10 Pro
    Version 10.0.15063 Build 15063
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name EIRE
    System Manufacturer Dell Inc.
    System Model XPS 8300
    System Type x64-based PC
    System SKU
    Processor Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 8 Logical Processor(s)
    BIOS Version/Date Dell Inc. A06, 10/17/2011
    SMBIOS Version 2.6
    Embedded Controller Version 255.255
    BIOS Mode Legacy
    BaseBoard Manufacturer Dell Inc.
    BaseBoard Model Not Available
    BaseBoard Name Base Board
    Platform Role Workstation
    Secure Boot State Unsupported
    PCR7 Configuration Binding Not Possible
    Windows Directory C:\WINDOWS
    System Directory C:\WINDOWS\system32
    Boot Device \Device\HarddiskVolume2
    Locale United States
    Hardware Abstraction Layer Version = "10.0.15063.0"
    Time Zone Pacific Daylight Time
    Installed Physical Memory (RAM) 16.0 GB
    Total Physical Memory 16.0 GB
    Available Physical Memory 10.1 GB
    Total Virtual Memory 32.0 GB
    Available Virtual Memory 24.1 GB
    Page File Space 16.0 GB
    Page File C:\pagefile.sys
    Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, Disabled by policy, TPM is not usable
    Hyper-V - VM Monitor Mode Extensions Yes
    Hyper-V - Second Level Address Translation Extensions Yes
    Hyper-V - Virtualization Enabled in Firmware Yes
    Hyper-V - Data Execution Protection Yes

    [Display]

    Item Value
    Name NVIDIA GeForce GTX 960
    PNP Device ID PCI\VEN_10DE&DEV_1401&SUBSYS_137519DA&REV_A1\4&DDE86B&0&0008
    Adapter Type GeForce GTX 960, NVIDIA compatible
    Adapter Description NVIDIA GeForce GTX 960
    Adapter RAM (2,147,483,648) bytes
    Installed Drivers C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll
    Driver Version 22.21.13.8205
    INF File oem5.inf (Section088 section)
    Color Planes Not Available
    Color Table Entries 4294967296
    Resolution 1920 x 1080 x 60 hertz
    Bits/Pixel 32
    Memory Address 0xFA000000-0xFB0FFFFF
    Memory Address 0xC0000000-0xD1FFFFFF
    Memory Address 0xD0000000-0xD1FFFFFF
    I/O Port 0x0000E000-0x0000EFFF
    IRQ Channel IRQ 16
    I/O Port 0x000003B0-0x000003BB
    I/O Port 0x000003C0-0x000003DF
    Memory Address 0xA0000-0xBFFFF
    Driver c:\windows\system32\driverstore\filerepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvlddmkm.sys (22.21.13.8205, 13.79 MB (14,456,912 bytes), 5/19/2017 6:04 PM)
  • havoc wrote:

    Having issues with graphics. grey pixelated cloud around the avatar

    System Information report written at: 06/09/17 14:26:04
    System Name: EIRE
    [System Summary]

    Item Value
    OS Name Microsoft Windows 10 Pro
    Version 10.0.15063 Build 15063
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name EIRE
    System Manufacturer Dell Inc.
    System Model XPS 8300
    System Type x64-based PC
    System SKU
    Processor Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 8 Logical Processor(s)
    BIOS Version/Date Dell Inc. A06, 10/17/2011
    SMBIOS Version 2.6
    Embedded Controller Version 255.255
    BIOS Mode Legacy
    BaseBoard Manufacturer Dell Inc.
    BaseBoard Model Not Available
    BaseBoard Name Base Board
    Platform Role Workstation
    Secure Boot State Unsupported
    PCR7 Configuration Binding Not Possible
    Windows Directory C:\WINDOWS
    System Directory C:\WINDOWS\system32
    Boot Device \Device\HarddiskVolume2
    Locale United States
    Hardware Abstraction Layer Version = "10.0.15063.0"
    Time Zone Pacific Daylight Time
    Installed Physical Memory (RAM) 16.0 GB
    Total Physical Memory 16.0 GB
    Available Physical Memory 10.1 GB
    Total Virtual Memory 32.0 GB
    Available Virtual Memory 24.1 GB
    Page File Space 16.0 GB
    Page File C:\pagefile.sys
    Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, Disabled by policy, TPM is not usable
    Hyper-V - VM Monitor Mode Extensions Yes
    Hyper-V - Second Level Address Translation Extensions Yes
    Hyper-V - Virtualization Enabled in Firmware Yes
    Hyper-V - Data Execution Protection Yes

    [Display]

    Item Value
    Name NVIDIA GeForce GTX 960
    PNP Device ID PCI\VEN_10DE&DEV_1401&SUBSYS_137519DA&REV_A1\4&DDE86B&0&0008
    Adapter Type GeForce GTX 960, NVIDIA compatible
    Adapter Description NVIDIA GeForce GTX 960
    Adapter RAM (2,147,483,648) bytes
    Installed Drivers C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll
    Driver Version 22.21.13.8205
    INF File oem5.inf (Section088 section)
    Color Planes Not Available
    Color Table Entries 4294967296
    Resolution 1920 x 1080 x 60 hertz
    Bits/Pixel 32
    Memory Address 0xFA000000-0xFB0FFFFF
    Memory Address 0xC0000000-0xD1FFFFFF
    Memory Address 0xD0000000-0xD1FFFFFF
    I/O Port 0x0000E000-0x0000EFFF
    IRQ Channel IRQ 16
    I/O Port 0x000003B0-0x000003BB
    I/O Port 0x000003C0-0x000003DF
    Memory Address 0xA0000-0xBFFFF
    Driver c:\windows\system32\driverstore\filerepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvlddmkm.sys (22.21.13.8205, 13.79 MB (14,456,912 bytes), 5/19/2017 6:04 PM)
    your running outdated video drivers update them.
  • snorri wrote:

    I know.. I just put the info in case there was a trick to use it ;)

    Btw, it's the fifth time I try to complete the mission.. All the field is cultivated and still not at 100% :/
    I have the same problem

    brandonb21 wrote:

    Jovink wrote:


    Love the demo looks good but found one bug
    • I cant get cab control to work with Left ctrl

    i also had this bug, go to settings, controls, look for "release mouse" and click on the empty box and press your left control button, then apply, then save.
    thanks it is working now
  • havoc wrote:

    Having issues with graphics. grey pixelated cloud around the avatar

    System Information report written at: 06/09/17 14:26:04
    System Name: EIRE
    [System Summary]

    Item Value
    OS Name Microsoft Windows 10 Pro
    Version 10.0.15063 Build 15063
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name EIRE
    System Manufacturer Dell Inc.
    System Model XPS 8300
    System Type x64-based PC
    System SKU
    Processor Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 8 Logical Processor(s)
    BIOS Version/Date Dell Inc. A06, 10/17/2011
    SMBIOS Version 2.6
    Embedded Controller Version 255.255
    BIOS Mode Legacy
    BaseBoard Manufacturer Dell Inc.
    BaseBoard Model Not Available
    BaseBoard Name Base Board
    Platform Role Workstation
    Secure Boot State Unsupported
    PCR7 Configuration Binding Not Possible
    Windows Directory C:\WINDOWS
    System Directory C:\WINDOWS\system32
    Boot Device \Device\HarddiskVolume2
    Locale United States
    Hardware Abstraction Layer Version = "10.0.15063.0"
    Time Zone Pacific Daylight Time
    Installed Physical Memory (RAM) 16.0 GB
    Total Physical Memory 16.0 GB
    Available Physical Memory 10.1 GB
    Total Virtual Memory 32.0 GB
    Available Virtual Memory 24.1 GB
    Page File Space 16.0 GB
    Page File C:\pagefile.sys
    Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, Disabled by policy, TPM is not usable
    Hyper-V - VM Monitor Mode Extensions Yes
    Hyper-V - Second Level Address Translation Extensions Yes
    Hyper-V - Virtualization Enabled in Firmware Yes
    Hyper-V - Data Execution Protection Yes

    [Display]

    Item Value
    Name NVIDIA GeForce GTX 960
    PNP Device ID PCI\VEN_10DE&DEV_1401&SUBSYS_137519DA&REV_A1\4&DDE86B&0&0008
    Adapter Type GeForce GTX 960, NVIDIA compatible
    Adapter Description NVIDIA GeForce GTX 960
    Adapter RAM (2,147,483,648) bytes
    Installed Drivers C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvldumd.dll
    Driver Version 22.21.13.8205
    INF File oem5.inf (Section088 section)
    Color Planes Not Available
    Color Table Entries 4294967296
    Resolution 1920 x 1080 x 60 hertz
    Bits/Pixel 32
    Memory Address 0xFA000000-0xFB0FFFFF
    Memory Address 0xC0000000-0xD1FFFFFF
    Memory Address 0xD0000000-0xD1FFFFFF
    I/O Port 0x0000E000-0x0000EFFF
    IRQ Channel IRQ 16
    I/O Port 0x000003B0-0x000003BB
    I/O Port 0x000003C0-0x000003DF
    Memory Address 0xA0000-0xBFFFF
    Driver c:\windows\system32\driverstore\filerepository\nv_ref_pubwu.inf_amd64_f9309145156afb40\nvlddmkm.sys (22.21.13.8205, 13.79 MB (14,456,912 bytes), 5/19/2017 6:04 PM)
    Install the Latest Nvidia Driver 382.53
  • test not good at this time ...

    config

    dual xeon e5-2670v1 2.6ghz low and turbo 3ghz on all cores (16) 3.3ghz on 2 cores per cpu (4)
    32gb ram
    980gtx 4gb
    ssd 500gb
    lasted nvidia driver 382.53


    game settings to minimum


    multi screen setup with 5 screens (only 1 to play the other to display other programs)..and (tested with all other screen deactivated)

    with my other screen activated when i scroll with the mouse wheel to change zoom in the game my other screen with google chrome (for example) scroll up and down (some times on the screen 2 3 4 or 5 assuming 1 is the game screen)


    result maybe 5 or 10 fps max 15
  • FarmerJosh wrote:

    Argon Dredd wrote:

    brandonb21 wrote:

    update your drivers for your video card
    Mine is up to date and I have the same bug.
    Maybe try to re-install them?
    I checked like half an hour ago right before playing the tech demo and there was no update and now there's one. lol Let's see if that will fix the bug.

    Update: The bug is gone. :)

    The post was edited 1 time, last by Argon Dredd ().

  • Only bugs I have found so far:

    1. No way to revert settings to default and no CFG file in any of the game's install directories to delete.
    2. Every time I change any game settings at all, the game "restores" to a tiny little window in the center of my screen and I have to re-maximize.
    3. Logitech G27 only seen as Combined Pedals, forcing us to have to drive FS17 style, which is annoying as heck.
    Faelandaea has been acknowledged as THE friendliest individual on the internet throughout all of gaming history.

    The post was edited 1 time, last by Faelandaea ().

  • Mark Schilling wrote:

    mmmBetty wrote:

    @Ludicrousfox there is a bug thread for this, and it's answered there.

    Cattle And Crops Tech Demo Bug Thread

    But the answer is either update your graphics card drivers or change your resolution. Dropping resolution seemed to fix a lot of these issues.
    Changing res doesn't work for me. I'm running the latest nvidia drivers too. Do you know if it supports SLI natively? Or are there working bits to improve performance as I'm using a pair of GTX 670's so really need SLI to work to get acceptable framerates?
    That aside, I can't get rid of the big grey blotch across my screen, which just renders it unplayable for me at the moment.

    Cheers,

    Mark.

  • Had things running on first install. Cannot get back in to game to get exact option I changed to create crash.
    Crash reporter itself crashes when trying to submit the bug report.

    Going to muck about with FS mod contest mods, because I can't really do anything useful as far as bug finding and reporting beyond this.
    Wish i could do more, sorry.
    Game looked good, I certainly don't expect optimization at this point.
    Functioned fairly well in the 40 minutes or so I had it running.
    Thanks for widescreen res support!
    And in game control config, YAY!!!!

    copy/paste of BugTrap data as follows.

    Exception reason

    CattleAndCrops.exe caused ACCESS_VIOLATION in module "C:\Windows\SYSTEM32\atio6axx.dll" at 0033:0000000076907D30, DrvPresentBuffers()+13685728 byte(s)

    Registers


    RAX=000000003FD90850 RBX=000000003FD72700
    RCX=000000003B01B0B0 RDX=0000000000000000
    RSI=000000001B0FD948 RDI=000000003FB2A9B0
    FLG=00010206 RBP=0000000000000001
    RSP=000000001B0FD898 RIP=0000000076907D30

    Stack Trace cant copy this

    Machine info

    OS Version: Windows 8
    Build Number: 9200

    Architecture: AMD-x64
    Number of Processors: 8
    Processors Descriptions:
    1. AMD FX(tm)-8350 Eight-Core Processor

    Current Memory Load: 18%
    Total Physical Memory: 16282 MB
    Available Physical Memory: 13250 MB
    Total Page File Memory: 16482 MB
    Available Page File Memory: 12562 MB

    =C:=C:\Program Files (x86)\Cattle and Crops\Game\Win64\Assets
    ALLUSERSPROFILE=C:\ProgramData
    AMDAPPSDKROOT=C:\Program Files (x86)\AMD APP\
    APPDATA=C:\Users\Jamie\AppData\Roaming
    CommonProgramFiles=C:\Program Files\Common Files
    CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
    CommonProgramW6432=C:\Program Files\Common Files
    COMPUTERNAME=DESKTOP-4KED3B1
    ComSpec=C:\Windows\system32\cmd.exe
    FPS_BROWSER_APP_PROFILE_STRING=Internet Explorer
    FPS_BROWSER_USER_PROFILE_STRING=Default
    GTK_BASEPATH=C:\Program Files (x86)\GtkSharp\2.12\
    HOMEDRIVE=C:
    HOMEPATH=\Users\Jamie
    LOCALAPPDATA=C:\Users\Jamie\AppData\Local
    LOGONSERVER=\\DESKTOP-4KED3B1
    NUMBER_OF_PROCESSORS=8
    OneDrive=C:\Users\Jamie\OneDrive
    OS=Windows_NT
    Path=C:\Program Files (x86)\AMD APP\bin\x86_64;C:\Program Files (x86)\AMD APP\bin\x86;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\GtkSharp\2.12\bin
    PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
    PROCESSOR_ARCHITECTURE=AMD64
    PROCESSOR_IDENTIFIER=AMD64 Family 21 Model 2 Stepping 0, AuthenticAMD
    PROCESSOR_LEVEL=21
    PROCESSOR_REVISION=0200
    ProgramData=C:\ProgramData
    ProgramFiles=C:\Program Files
    ProgramFiles(x86)=C:\Program Files (x86)
    ProgramW6432=C:\Program Files
    PSModulePath=C:\Program Files\WindowsPowerShell\Modules;C:\Windows\system32\WindowsPowerShell\v1.0\Modules
    PUBLIC=C:\Users\Public
    SystemDrive=C:
    SystemRoot=C:\Windows
    TEMP=C:\Users\Jamie\AppData\Local\Temp
    TMP=C:\Users\Jamie\AppData\Local\Temp
    USERDOMAIN=DESKTOP-4KED3B1
    USERDOMAIN_ROAMINGPROFILE=DESKTOP-4KED3B1
    USERNAME=Jamie
    USERPROFILE=C:\Users\Jamie
    windir=C:\Windows
    __COMPAT_LAYER=ElevateCreateProcess

    As far as i can tell, the bug reporter sends the info, but not sure.

    So, wall of text, apologies.

    Just realized it is reporting Win 8 above, this is incorrect.
    Win 10 pro 64 bit OS.
    R5 1600x / Crosshair 6 Hero / 16 GB Gskill FlareX 3200 / Vega 64 LC/ Samsung 960 Evo NVMe
    M.2 500GB / Samsung 840 Evo Sata 6 500Gb / 1TB WD Blue / Thermaltake 360mm AIO
    / Corsair HX 850w / Phanteks Enthoo Pro / Win10 Home 64 bit / LG 34UM88C 3440 x 1440 21 x 9 monitor.

    The post was edited 1 time, last by Chicken ().