Launchpad (Linux, Ubuntu) doesn't launch the game (Solution: libSDL2-2.0.so.0))

  • Launchpad (Linux, Ubuntu) doesn't launch the game (Solution: libSDL2-2.0.so.0))

    Hello

    I'm make a new installation of ubuntu 19.04 by erasing all my HD which containing programs and personnals files.

    I make installation of CnC without problems. When i want play the game, the launcher doesn't launch the game !! Nothing happens ! :(

    I installed CnC in the folder /opt/CattleAndCrop, not in my home folder. See the debug.log below.

    Thanks for your help

    Display Spoiler

    CattleAndCrops has crashed with: SIGABRT !
    In Thread: 139709672868224 ("CattleAndCrops.")
    Backtrace:
    CattleAndCrops[0xb550ea]
    CattleAndCrops[0xb55377]
    /lib/x86_64-linux-gnu/libpthread.so.0(+0x13f40)[0x7f10b32ebf40]
    /lib/x86_64-linux-gnu/libc.so.6(gsignal+0xc7)[0x7f10b312eed7]
    /lib/x86_64-linux-gnu/libc.so.6(abort+0x121)[0x7f10b3110535]
    /lib/x86_64-linux-gnu/libdbus-1.so.3(+0xb78d)[0x7f10afc4d78d]
    /lib/x86_64-linux-gnu/libdbus-1.so.3(_dbus_strdup+0x0)[0x7f10afc6f350]
    /lib/x86_64-linux-gnu/libdbus-1.so.3(dbus_type_is_basic+0x63)[0x7f10afc6a403]
    /lib/x86_64-linux-gnu/libdbus-1.so.3(dbus_message_append_args_valist+0x61)[0x7f10afc612b1]
    /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0(+0xd99d4)[0x7f10b3b0e9d4]
    /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0(+0xda258)[0x7f10b3b0f258]
    /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0(+0xdaf46)[0x7f10b3b0ff46]
    /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0(+0xdb37f)[0x7f10b3b1037f]
    /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0(+0xda5ef)[0x7f10b3b0f5ef]
    /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0(+0xcaa66)[0x7f10b3affa66]
    /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0(+0xd2920)[0x7f10b3b07920]
    /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0(+0xb6314)[0x7f10b3aeb314]
    /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0(+0x182ef)[0x7f10b3a4d2ef]
    CattleAndCrops(_ZN2C46Engine10InitializeEPKcS2_+0xb5)[0xaa20d5]
    CattleAndCrops(main+0xfb)[0xb5548b]
    /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xeb)[0x7f10b3111b6b]
    CattleAndCrops[0xa06699]
    Alex

    ----------------------------------------------------------------------------------------------
    Intel(R) Core (TM) i7-4790 CPU @ 3,60 Ghz x8
    RAM 8Gio
    Geforce GTX 760
    Ubuntu 19.04 64bit
  • In the German part of the forum had a user a similar problem with the launcher under Linux. Maybe the solution will help you, but it is in German. If this does not work, @caedes certainly has a solution.

    caedes wrote:

    Danke für die Info!
    Ich glaub ich habe herausgefunden woran es liegt - ein Bug in der mitgelieferten libSDL2-2.0.so.0.
    (Die wird nur genutzt wenn die Version auf deinem System älter ist - was bei Steam nie der Fall ist weil Steam eine neuere Version mitliefert - deshalb ist das Problem wohl bisher nicht aufgefallen).
    Wie auch immer, ich glaube ich konnte den Bug in SDL2 beheben - kannst du folgendes probieren:
    • In Cattle-and-Crops/Game/Linux/libs/sdl2/ die Datei libSDL2-2.0.so.0 umbenennen (ein _bk oder so anhängen, was auch immer)
    • Die libSDL2-2.0.so.0 aus dieser zip in den selben Ordner reinkopieren
    • Spiel starten
    • Bescheid sagen ob's geholfen hat :)

    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • yeah, try downloading forum.cattleandcrops.com/attachment/6466-cnc-sdl2-upd-zip/ and replace /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0 with the one in the zip

    or, install libSDL2 on your system, the one in Ubuntu 19.04 should be new enough for CnC to prefer it over the bundled one: sudo apt install libsdl2-2.0-0

    The post was edited 2 times, last by caedes ().

  • caedes wrote:

    yeah, try downloading forum.cattleandcrops.com/attachment/6466-cnc-sdl2-upd-zip/ and replace /opt/CattleAndCrops/Game/Linux/libs/sdl2/libSDL2-2.0.so.0 with the one in the zip

    or, install libSDL2 on your system, the one in Ubuntu 19.04 should be new enough for CnC to prefer it over the bundled one: sudo apt install libsdl2-2.0-0
    Thanks a lot, it works well !
    I didn't search in german forum beacuse i'm not german speaker so it's quite difficult for me !
    Alex

    ----------------------------------------------------------------------------------------------
    Intel(R) Core (TM) i7-4790 CPU @ 3,60 Ghz x8
    RAM 8Gio
    Geforce GTX 760
    Ubuntu 19.04 64bit