Help with loghitech G29

  • @gheazu Hey, you also have to assign the axes in the controller.

    If you are interested I can also provide you with my steering wheel config.
    Images
    • 20190303121623_1.jpg

      1.42 MB, 2,597×2,024, viewed 101 times
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • Did you also select the item vehicle?
    You have to click on the axis you want to occupy and then turn your steering wheel in the desired direction.
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • Florian1986 wrote:

    @gheazu Hey, you also have to assign the axes in the controller.

    If you are interested I can also provide you with my steering wheel config.
    When i try to bind Left or Right and i move my whell the game dos not do nothing the cell with the key dos not show Whell axis it stays empty
    If i go to calibration and move it it shows that works, it cannot be bind :(

    Acceleration and brake works left and right not
  • Could you take a screenshot of the calibration and the assignment of the buttons?

    I just tried the assignment with me and it worked. What value is your deadzone set in the calibration of the steering axle?
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • So it works now?
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • no
    I canto bind left and right. The game thinks i try to bind last key not the one i press check the video. And after you try 2 or 3 times it gets bind but all calibration gos crazy and you need to rebind all again and you are stuck in a loop
    P.S. The acceleration dos not act like a pedal in the game is full acceleration or non no sensitivity if you push the pedal just a little it accelerate to max same with brake pedal no sensitivity , left or right is dos not mater if you move the sterringwheel a little to left it takes full left etc...
  • Yes, I understood what the problem is. You have to set the deadzone of the calibration lower, try it as in my picture.
    The assignment of the keys you have done almost right, if you have occupied the axis for the left you do not have the right for the right, otherwise it wants to change the left again! So only show on the left that is important!
    Images
    • 20190303132559_1.jpg

      1.87 MB, 3,840×2,160, viewed 103 times
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • As I said I can only offer then that I send you my file of Configuratin.
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • I uploaded it to google drive. Here is the link to it.

    drive.google.com/file/d/1JqX4_…EvyETINV/view?usp=sharing

    Insert the "input_steam" in your profiles.
    Images
    • Unbenannt.png

      25.52 kB, 1,489×720, viewed 96 times
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • :)) still bug and annoying now all is ok except Brake pedal is acceleration Clutch pedal is Brake. Normal shod not be a problem but G29 Brake pedal is different is stronger and has a limitation at half so it fill more natural (impossible to play like that)
    Thank you
    Images
    • 704030_20190303162055_1.png

      996.03 kB, 1,920×1,080, viewed 104 times
  • Then you measure the power for it in the Logitech software still set. I have the sensitivity there to 100% for both pedals.
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • I was just watching your video.
    I noticed that you don't press the "Calibrate" button before moving the pedals or steering wheel and follow the instructions there.


    So you have to press the button "Calibrate" first, then it says that you have to move the steering wheel or the pedals once to the stop, then click "OK" 2x without moving anything.


    Now you can see in the display how the setting has changed.

    Then, when you have calibrated the respective axis, you can set the deadzone.
    Vote for Vulkan Support in CNC!
    Desktop: i7 3770K, 8GB 1600Mhz, AMD RX Vega 56 <-- alles unter Wasser an BenQ XL2730Z(1440p@144Hz)..... Windows 10 64bit
    Laptop: i7 7700HQ,16GB 2400Mhz, Nvidia GTX 1080@120Hz 17,3" G-Sync IPS, 256GB SSD Samsung PM961 + 1TB HDD

    Der Ursprung aller Macht ist das Wort.
  • i do press it :( After i setup first one and move to the next the game say i all ready bind that key.
    For example i press on key for Froward - then i push acceleration pedal all good game set it up, i move froward and pres the empty box for brake when i push the brake pedal game things i push the acceleration and say the key is all ready bind, i need to try again then it works, and so on for the all keys. After i manage to set them up and enter the game the brake pedal is acceleration and the clutch pedal is the brake (FYI i never set up a clutch in this game)

    Edit:
    This is the only problme now Break is acceleration and clutch is break and if i press acceleration it go full throttle
    O and when you take you foot out of acceleration (break pedal my case) the tractor dos not roll it auto stops )

    Im open for suggestion if one has time (if you think im a noob and i have no idea how to do it i do have 200 + h in EST 2 i setup my G29 100 times with manual gearbox)

    The post was edited 3 times, last by gheazu ().

  • gheazu wrote:

    [..]
    Im open for suggestion if one has time (if you think im a noob and i have no idea how to do it i do have 200 + h in EST 2 i setup my G29 100 times with manual gearbox)
    Yes, there are software (like ETS2) which work very well. :)
    And there are some people having problems with CaC.
    Its e.g. not easy to accept to bind the accelrator pedal to a forward function ceeping in mind what this means at a reverse gear.
    Lenkrad und CaC - Geht halt nicht bei jedem.
    Kritische Geister befördern ein Projekt.
    Mods handeln nach Couleur!
  • @Lee01Mr The G29 works in CNC I use it too and have no problems. Here in the forum others play with it, but also different YouTubers. Nice to hear that your G27 works in CNC. :)
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • all drivers are up to date i use a G903 G810 and G29. Sort it out the acceleration pedal as i posted up the problem is when you lift your foot of the pedal the machine stops and when you are in revers gear the break peal acts like acceleration. all of this are annoying to me and brake the game play. Im a little disappointed that for PC only game they decided to work on a controller device first of steering wheel as i see the majority of us use steering wheels and not controllers
  • Lee01Mr wrote:

    Did you select "manual transmission" in the gameplay section? The way you describe your problem it sounds like that is your problem. Can you make a screenshot of the options you ticked? Makes it easier for us to understand ;)
    I fail to understand how this is my problem as my G29 works perfect in EST2 FS XX City car driving, now i already spend over 2h to get this setup and is still not working decent. When i bind acceleration i pres the acceleration pedal im not that idiot.
    And now lets say im a idiot and have no idea how to setup my G29 don't you think this is C&N problem to make it easy to access for all type of players in order to sell there product ?

    We move far away from the subject, your intention is good only you point in the wrong way :)
    Images
    • .png

      704.3 kB, 1,920×1,080, viewed 98 times
  • I'm sticking with it, the problem is you don't calibrate the pedals!
    As long as you don't do that, we won't get any further here.
    Vote for Vulkan Support in CNC!
    Desktop: i7 3770K, 8GB 1600Mhz, AMD RX Vega 56 <-- alles unter Wasser an BenQ XL2730Z(1440p@144Hz)..... Windows 10 64bit
    Laptop: i7 7700HQ,16GB 2400Mhz, Nvidia GTX 1080@120Hz 17,3" G-Sync IPS, 256GB SSD Samsung PM961 + 1TB HDD

    Der Ursprung aller Macht ist das Wort.
  • I'm not moving away from the problem if you think that. And ETS2 FS19 work different in key bindings ;) . All I ask is if you can make a screenshot of your"gameplay" section because there is something you miss. Or like Danny says calibrate your pedals. You have to bind some inputs as sliders etc etc. If you have teamviewer we can help you better :) .
    Proper Sim gamer. Rally games tractor and truck games. Bus games and train games you name it :)

  • DannyA4 wrote:

    I'm sticking with it, the problem is you don't calibrate the pedals!
    As long as you don't do that, we won't get any further here.
    You are funny i post a video up where i calibrate my G29 as you see i pres the right pedal :) but you keep tell me that i confuse acceleration with brake pedal :)

    Again im not a idiot i know how to calibrate my steering wheel and in all games i have play i never had this problems.

    The problems are:
    After you lift your foot of acceleration pedal the tractor stops (it dos not roll)
    When you are in revers gear (manual gear box) the brake pedal acts like acceleration pedal.

    I have uninstall the game do not bother it is clear the game has problems when it comes to Sterling wheels you can blame me all day :) i do not mind
  • I'm sorry but the issue is that you did not calibrate. Clicking "Configure Axis" is not the only thing you have to do. You forgot to press "calibrate" on the different axis as Danny already mentioned. Your video shows the problem actually. The axis is always at value -1 instead of 0 because you did NOT calibrate the axis.
  • why do i keep say i did all that and you do not understand ? must be the language barrier ;)

    Ok here we go again:

    I have done all what you guys tell me 10 times.
    I have reinstall the game
    I have use @Florian1986 config file

    After more 2h of configure all this i have the fallowing problems
    After you lift your foot of acceleration pedal the tractor stops (it dos not roll)
    When you are in revers gear (manual gear box) the brake pedal acts like acceleration pedal.

    Thank you for your support.

    P.S. im happy to tray any think else, i have did all what all of you have suggested me 10 times each.
  • @gheazu I watched your video above and it looks like you didn't calibrate which is why they're telling you again to calibrate. When calibrated (click calibrate button for accelerator and brake) the accelerator and brake will be all white when not pressed and fill up with color when pressed. Yours are backwards. Also set your dead zones to zero (or close to zero) to get full range of motion on wheel and pedals. Many people, including me, are using wheel and pedals just fine so I believe we can get this solved eventually :)