Speichern mit aktivem Helfer/ Mögliche Lösung im Thread

  • Speichern mit aktivem Helfer/ Mögliche Lösung im Thread

    Ich weiß, dass mit aktivem Helfer noch nicht Fehlerfrei gespeichert wird. Ich wollte hier mal ein Savegame mit den Problemen bereitstellen. Auf Steam hat sich ein User über Arbeiter beschwert, die nach dem Laden des Spielstandes von alleine anfangen. Ich hab mir das Savegame mal angesehen und er hatte während der Getreide Mission gespeichert in der ein Abfahrer tätig ist. Nach dem Laden des Spielstandes erstellt das Spiel wieder eine Aufgabe in die aber diesmal auch der Drescher eingeteilt ist. Zudem gibt es in dem Savegame nach Laden noch einen aktiven Helfer auf dem Hof der zum mittleren Hofsilo fährt. Der Traktor sieht eigentlich regulär abgestellt aus, weshalb ich denke, dass dort vor dem Speichern kein Helfer eingeteilt war. Eventuell gibt es hier noch ein anderes Problem bei dem Helfer nach Laden eingeteilt werden.

    Savegame: Download
  • hallo,
    weil das Topic des Threads passt meine Frage:

    Sollen wir nur savegames bereitstellen die beim Laden abstürzen oder auch savegames bei denen die Helfer nach dem Laden des Spielstandes nicht funktionieren?

    In dem MBB post steht
    "crash?" und "Helfer verwirrt?"

    Aber auf letzteres wird ja im Spiel hingewiesen, deswegen weiss ich nicht, ob man es melden soll oder nicht.

    Grüße
    Nachtfalke
  • Savegames die mit einem aktiven Helfer gespeichert wurden würde ich jetzt nicht mit einbeziehen da ja explizit darauf hingewiesen wird nicht mit aktivem Helfer zu speichern! Demnach sollte man eventuell vorher abwägen ob man die Aufgabe schafft oder nicht, gegebenenfalls den Task vorher abbrechen wenn man es nicht Schaft es zu erledigen da die Möglichkeit ja besteht das der Helfer an der Stelle weiter macht wenn man den Task dann neu erstellt.
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • @Florian1986 hast du das mal beim dreschen probiert ob der Helfer an der Stelle wo abgebrochen wurde wieder anfängt? Sonst werde ich es heute Abend testen
    AMD Phenom II X4 945 3.0Ghz - 8Gb Ram - Gforce 660GTX 2Gb - Logitech Saitek Heavy Equipment Bundle with 2 side controllers

    :S
    My English is not perfect, thank you for being indulgent...
    Mein Deutsch ist nicht perfekt, Danke für ihr Verständnis...
    :S
  • Beim Dreschen hab ich es noch nicht getestet @Fck54 habe es nur mit dem Grubber, Pflug und Sähmaschine getestet.
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • Hä, bin total verwirrt.

    1.) Es steht in der Warnung, dass das speichern bzw laden mit aktiven Helfern noch nicht klappt, aber das bedeutet doch nicht, dass ich nicht speichern darf und den Task abbrechen muss bevor ich speichere?

    2.) unter welcher Bedingung fangen die Helfer wieder an bzw machen dor weiter, wo sie aufgehört haben? Meinst du im Task "Von vorne beginnen"? Diese Funktion ist doch angeblich nicht funktional auch wenn sie EA früher mal war.

    3.) ich speichern immer, auch mit laufenden Tasks. Manchmal machen sie nach dem Laden weiter, manchmal nicht.

    Freue mich über Aufklärung.


    Grüße
    Nachtfalke
  • @Nachtfalke
    1. in dem Fall ist das speichern auf eigene Gefahr. Du musst auch nicht abbrechen, es wäre eine Möglichkeit die ich damit aufzeigen wollte.

    2. als Beispiel: du brichst einen laufenden Task ab und speicherst dann, lädst du diesen Spielstand wieder und erstellst den selben Task wieder ohne das Häkchen bei „von vorne beginnen“ sollte der Helfer an dem Punkt weiter machen an dem er auf dem Feld steht! Die Funktion „von vorne beginnen“ ist selbstverständlich aktiv im Spiel und bewirkt dann genau das was sie aussagt, nämlich das der Helfer beginnt von vorne! Wäre schön zu wissen wer das mal geschrieben hat...es gab in einer der ersten Version damit mal ein Problem aber das wurde schon lange gefixt.

    3. genau das ist das Problem dabei, manchmal funktioniert es und manchmal nicht. Im schlimmsten Fall Crasht dir das savegame wenn du mit aktivem Helfer speicherst. Ich wollte damit aufzeigen mit der abbrechen und neu erstellen der Task wie du diesen eventuellen Fehler umgehen oder minimieren kannst.
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • So zum Thema "von vorne beginnen" habe eine Task erstellt auf Feld 3 mit dem Axion einem Gewicht und einem Grubber, das Häkchen habe ich nicht gesetzt. Der Helfer fährt einfach an der Langen Seite des Feldes runter und dann zurück zum Hof da das Feld schon zu 100% gegrubbert ist. Selben Task nochmal allerdings mit dem gesetzten Häkchen, der Helfer fährt zum Feld wartet kurz und dann fährt er schräg über das Feld nach links unten und beginnt seine Arbeit

    Danach habe ich zwei Bahnen Pflügen lassen das Häkchen war gesetzt er fuhr schräg über das Feld und begann die Arbeit, dann den Task gelöscht neu erstellt und diesmal ohne das Häkchen. Daraufhin fährt er in die nächste Bahn und macht weiter als wäre nichts gewesen.


    Man sieht sehr schön das er eine Schleife gefahren ist als der Task neu erstellt wurde und in der nächsten Bahn angefangen hat.


    Als nächstest habe ich den Task mit dem Axion wieder gelöscht und einen neuen mit dem Deutz erstellt ohne das Häkchen zu setzen, dieser fuhr zum Feld und fing bei der letzten Bahn an die der Axion zuvor gepflügt hatte!
    Also die Funktion "von vorne beginnen" ist implementiert und funktioniert, ebenso das der Helfer weitergemacht hat wo man aufgehört hat oder wenn man einen neuen Task erstellt macht dieser dann weiter wo der letzte aufgehört hat.
    Images
    • 0.png

      4.35 MB, 1,920×1,080, viewed 17 times
    • 2.png

      4.25 MB, 1,920×1,080, viewed 15 times
    • 3.png

      4.17 MB, 1,920×1,080, viewed 15 times
    • 1.png

      4.02 MB, 1,920×1,080, viewed 16 times
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • Nachtrag zu meinem obigen Post:

    Ich bin zwei Bahnen im selben Muster des Helfers gefahren und habe dann einen Task erstellt allerdings macht er nicht weiter und fährt zum Hof.

    Getestet habe ich es auch mit der Sähmaschine selbes vorgehen wie beim Pflügen die Funktion "von vorne beginnen" funktioniert auch da ohne Probleme. Ebenso wenn man den Task abbricht und anschließend neu erstellt, auch hier macht der Helfer weiter.
    Images
    • 1.1.png

      3.92 MB, 1,920×1,080, viewed 13 times
    • 2.2.png

      4.18 MB, 1,920×1,080, viewed 13 times
    • 3.3.png

      3.85 MB, 1,920×1,080, viewed 14 times
    • 4.4.png

      4 MB, 1,920×1,080, viewed 14 times
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • Hallo,

    vielen Dank für Eure Tests. Also ich war mir auch ziemlich sicher, dass es bei v0.2.2.2 nicht so gut funktioniert hat. Was wir aber hier festgestellt haben ist, dass es klappt, solange Helfer alleine die Aufgabe erledigen. Wenn man selbst als "Mensch" darin rum gepfuscht hat, dann finden die Helfer den Einstiegspunkt nicht richtig.

    Insofern könnte man die Version auf 0.2.6.0 setzen mit der kleinen Einschränkung, dass man eben selbst nicht mitmachen darf.

    Persönlich finde ich das sehr hilfreich zu wissen, dass es klappt, denn in der Vergangenheit habe ich manchmal den PC laufen lassen und 20min gewartet, nur weil der Helfer noch nicht ganz fertig war und ich keinen Bock hatte zu speichern und nach dem Speichern klappt nichts mehr.


    Grüße
    Nachtfalke
  • Hab den Themen Titel mal ergänzt sowie die Versionsnummer
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • Hallo,

    ich musste heute zwangsläufig auf Feld 3 die Säarbeiten unterbrechen. Habe Feld 3 Säen lassen mit Mais. Der Helfer war (fast) fertig mit den bahnen, es fehlte aber definitiv noch das Vorgewende. ich speichgerte (mit laufendem Task) und beendete das Spiel.

    Als ich es wieder geladen habe hat der Helfer noch eine Bahn gezogen und fuhr zum Hof und brach ab.

    Ich habe danach mehrmals (2-3) einen neuen Task erstellt
    • einmal ohne Haken bei "Von Vorne beginnen", klappte nicht. Er fuhr einmal ums Feld und Schluß war.
    • dann mit Haken bei "von vorne beginnen", da fuhr er ums Feld und begann die Bahnen neu zu säen, wie eben "von vorne beginnen" zu intepretieren ist, ich brach es ab
    • dann nochmal ohne Haken bei "Von Vorne beginnen" und dann klappte es. Man konnte das dann auch gut im KI Debug sehen, dass er die bearbeitete Fläche nun (endlich) erkannt hat.



    Der Erfolg hängt scheinbar etwas vom "Zufall" ab, es hilft also, dass man es ggf mehrmals probiert.


    Grüße
    Nachtfalke
  • Hallo,

    jetzt konnte ich das oben zu sehende Feld 3 erneut nicht fertig säen lassen, weil die Miete für den Traktor abgelaufen war ... Also neuen Traktor geliehen und neuen Task erstellt. Es klappte wieder oft nicht so zuverlässig.


    Wie hier zu sehen fährt er einmal die Strecke am Feldrand entlang und dann war es das. "Vor vorne beginnen" war abgeschaltet.



    Zwischenzeitlich noch 2x (insgesamt 3x) mit Haken raus bei "Von vorne beginnen" probiert, ohne Erfolg.
    Dann den Haken einmal rein gemacht bei "Von vorne beginen", task gestartet und direkt wieder gelöscht.

    Das Bild zeigt nun den nächsten Versuch bei Haken raus "Von Vorne beginnen":



    Man erkennt, dass er nun einen kleinen Streifen "rot" markiert hat. Das war das, was ich zuvor habe säen lassen, bevor der Traktor weg war, wegen der Miete. Habe da dann einmal eine Bahn saen lassen, dann wollte er wenden und weiterhin über bereits gesätes drüber, habe den Task dann gelöscht.




    DANACH habe ich erneut einen mit Haken raus bei "von vorne beginnen" erstellt und ENDLICH hat er das als gesät erkannt, was es auch war, 1-2 Bahnen hat er nicht erkannt.



    Also ich weiss nicht, wo die Infos gespeichert werden, welche Teile bearbeitet sind und welche nicht, aber ich habe das gefühl, dass er manchmal einfach nicht die richtige Variable aufruft oder aus einer Schleife nicht raus kommt. Wenn man dann mal "Von vorne beginnen" anhakt und loslaufen lässt, dann springt er wahrscheinlich aus einer Schleife raus und beim nächsten Einstieg klappt es dann besser.

    Ich weiß jetzt aber auch nicht, wie man das noch besser beschreiben kann oder gezielter testen kann. In jedem Fall klappt es leider nicht zuverlässig aber mit der nötigen Geduld in einer Early Access kommt man ans Ziel. ;-))


    Grüße
    Nachtfalke
  • Hallo,

    ich bin es leider schon wieder. Habe ich etwas übersehen oder wieder falsch kombiniert? Ich habe:
    Tucano + Mähwerk + Hänger (Helfer)
    Arion + 2x Strautmann Hänger (Helfer)
    Feld #33 (habe ich gekauft)

    Habe ich zur Ernte geschickt und die Option "Von vorne Beginnen" ist gar nicht verfügbar. Ich hatte leider die Ballenmission vorzeitig beendet, wollte dann noch den Rest abernten und dachte, ich könnte dort weiter ernten.

    Gibt es die Option "Von vorne beginnen" nur unter gewissen Konstellationen?


    Grüße
    Nachtfalke
  • In einem Ernte-Task ist diese Funktion nicht vorhanden! An dieser Stelle im Ernte-Task kannst du die Strohablage in dem Fall anklicken.
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole
  • Florian1986 wrote:

    In einem Ernte-Task ist diese Funktion nicht vorhanden! An dieser Stelle im Ernte-Task kannst du die Strohablage in dem Fall anklicken.
    Ist das beim Erntetask grundsätzlich nicht so, hast du es zufällig mal beim Jaguar probiert?
    War das noch nie so, dass man es dort nutzen kann?

    Vielleicht ist es auch das, was TheCoCe meinte, dass diese Funktion bei der Ernte entfernt wurde, bei den anderen Aufgaben aber nicht?


    Grüße
    Nachtfalke
  • In einem Ernte-Task gab es diese Funktion meines Wissens noch nie. Habe es beim Jaguar getestet und mit dem Tucano. Was definitiv aber nicht passt ist wenn man einen Ernte-Task einstellt das beim Häcksler die Möglichkeit der Schwadablage einzustellen ist, aber das lässt sich anpassen für ein späteres Update.

    Aber nach zweimal neu erstellen des Ernte-Tasks wenn ich den Drescher an die Stelle gefahren habe wo er weitermachen soll funktionierte dies. Man muss es halt öfter probieren!
    CPU: Intel Core i7-8700,6x3700 MHz Turbo bis zu 4700 MHz, CPU-Kühler: CSL Maelstrom 120 Wasserkühlung, 500GB SSD +3000GB Seagate/Western Digital, 32GB DDR4-Ram, GTX 1080 Ti Armor 11G OC 11GB GDDR5X, Mainboard: ASUS Prime Z370-P, Netzteil: 700 Watt Power Boost 80+ Gold, Windows 10 Home 64-Bit, Logitech G29 und Saitek Seitenkonsole