Saitek Heavy Equip. Wheel and Pedal Config Fehler

  • Saitek Heavy Equip. Wheel and Pedal Config Fehler

    Beim Saitek Lenkrad gibt es noch diverse Probleme in der 0.1.4

    Da es unterschiedliche Fehler in Launcher und Steam sind, gehe ich davon aus, dass es nicht am Lenkrad selbst liegt.

    Fehler 1 nur in der Lanucherversion:
    (Betrifft die Pfeiltasten neben dem linken Analogstick)

    Egal welche Funktion ich auf die "Pfeil hoch" Taste lege wird diese Funktion ingame mit der "Pfeil runter" Taste getriggert. Wenn diese zusätzlich mit einer anderen Funktion belegt ist, werden beide getriggert. Die "Pfeil hoch" Taste bleibt ingame funktionslos, obwohl sie in den Einstellungen korrekt erkannt wird.

    Fehler 2 nur in der Steamversion:
    (Betrifft die Lenkachse des Lenkrades)
    Wenn das Lenkrad in einer Session das erste mal nach links gedreht wurde, läuft der Charakter nach links, wenn das Lenkrad in Ruhestellung ist. Andere Richtungseingaben überschreiben diese Fehlfunktion, was bedeutet, dass sich der Charakter in alle Richtungen bewegen lsäät, aber nicht zum Stillstand zu überreden ist.


    @Memphis
    Kannst du bitte mal klären, ob die beiden Fehler eigene Threads benötigen? Dann würde ich noch Splitten. Danke.

    MfG

    Radler
  • Für Fehler 2 musst du im Moment eine höhere Deadzone einstellen. Dein Lenkrad steht ohne Deadzone einfach nie richtig in der Mitte wodurch immer entweder nach links oder nach rechts laufen getriggert wird.
    Es ist geplant die Steuerung für Charakter, Fahrzeug und so weiter zu trennen. Ich meine, daran wird gerade auch gearbeitet.
  • Oder neue kalibartion durch gehen , meiner hat den Problem nicht..
    AMD Phenom II X4 945 3.0Ghz - 8Gb Ram - Gforce 660GTX 2Gb - Logitech Saitek Heavy Equipment Bundle with 2 side controllers

    :S
    My English is not perfect, thank you for being indulgent...
    Mein Deutsch ist nicht perfekt, Danke für ihr Verständnis...
    :S
  • TheCoCe wrote:

    Für Fehler 2 musst du im Moment eine höhere Deadzone einstellen. Dein Lenkrad steht ohne Deadzone einfach nie richtig in der Mitte wodurch immer entweder nach links oder nach rechts laufen getriggert wird.
    Es ist geplant die Steuerung für Charakter, Fahrzeug und so weiter zu trennen. Ich meine, daran wird gerade auch gearbeitet.
    Das werde ich testen, allerdings bezeifele ich, dass das die Ursache ist, da ich im Launcher eine Deadzone von 0 eingestellt habe, ohne, das der Fehler auftritt.



    Fck54 wrote:

    Oder neue kalibartion durch gehen , meiner hat den Problem nicht..
    Kalibriert habe ich ebenfalls, hat aber nichts gebracht.
  • Geht mir genauso, meins ist auch noch von Saitek und hat ein Rotz-Poti drin! :thumbdown:
    Vote for Vulkan Support in CaC!
    Desktop: i7 3770K, 8GB 1600Mhz, AMD RX Vega 56 <-- alles unter Wasser an BenQ XL2730Z(1440p@144Hz)..... Windows 10 64bit
    Laptop: i7 7700HQ,16GB 2400Mhz, Nvidia GTX 1080@120Hz 17,3" G-Sync IPS, 256GB SSD Samsung PM961 + 1TB HDD

    Der Ursprung aller Macht ist das Wort.
  • Das Problem mit der "up"-Taste ist wohl Spiel bedingt, ich habe es ebenfalls mit meinem G25 und der up Taste.
    Meine auch, hier irgendwo im Forum von jemand anderem gelesen zu haben, welcher ein anderes Lenkradfabrikat besitzt, aber auch das up-Tasten-Problem hatte.
    Vote for Vulkan Support in CaC!
    Desktop: i7 3770K, 8GB 1600Mhz, AMD RX Vega 56 <-- alles unter Wasser an BenQ XL2730Z(1440p@144Hz)..... Windows 10 64bit
    Laptop: i7 7700HQ,16GB 2400Mhz, Nvidia GTX 1080@120Hz 17,3" G-Sync IPS, 256GB SSD Samsung PM961 + 1TB HDD

    Der Ursprung aller Macht ist das Wort.
  • Das Problem mit der Up Taste konnte ich reproduzieren, tritt mit allen DirectInput Geräten auf. Wird im nächsten Update behoben sein.

    Das "nach links laufen" Problem liegt wohl daran, dass unsere Standardconfig für's Saitek eine Deadzone von 0 hat, und ich beim Erstellen der Standardconfig wohl vergessen hatte, dieses Lenkrad auch "zu Fuß" zu testen.
    Bei mir reicht es aus, die Deadzone auf 0.01 zu setzen - ist das bei euch auch so?
    Oder braucht ihr eine größere Deadzone beim Saitek Heavy Equipment Wheel? Welche?
    (Hier würde mich insb. auch der benötigte Wert für "Altware" interessieren).

    The post was edited 1 time, last by caedes ().

  • @caedes Das Problem betrifft auch das Logitech Driving Force GT. Kleine Deadzone reicht hier schon (mag nur keine Deadzones :) ).

    Wolltet ihr das nicht demnächst ändern für Maschinen und zu Fuß getrennt ? Dann wäre das Problem ja nicht mehr so groß, wenn man die Achsenbelegung bei "zu Fuß" weglassen könnte ? Natürlich nur für die die es mögen.
    Grüße

    Sir Poldi ;)

    Display Spoiler

    Intel Core i7 860 @ 2.8GHz
    16GB RAM
    NVIDIA GeForce GTX 1060 6GB
    250 GB SSD SanDisk
    Windows 10 Pro 64Bit
  • deadzone kann auch noch kleiner in den input.cfg eingestellt werden.
    AMD Phenom II X4 945 3.0Ghz - 8Gb Ram - Gforce 660GTX 2Gb - Logitech Saitek Heavy Equipment Bundle with 2 side controllers

    :S
    My English is not perfect, thank you for being indulgent...
    Mein Deutsch ist nicht perfekt, Danke für ihr Verständnis...
    :S
  • Sehr gut, dann werde ich den Default Wert in unseren Standard Configs entsprechend anpassen.
    (Wer allerdings das Lenkrad schon mit der alten Standardconfig benutzt hat, hat den alten Deadzone Wert in seiner eigenen input.cfg, die Vorrang hat, muss das also selbst im Kalibrierungsmenü anpassen. Aber das ist ja nicht schwer, wenn man's weiß)

    Danke für die Rückmeldung!