Pinned Early-Access Community Release v0.1.0.2 - Changelog

    • Early-Access Community Release v0.1.0.2 - Changelog

      We hope all of you had a good start into the new year!


      With today’s update v0.1.0.2 we have fixed more bugs. As always, check the changelog for improvements, changes and fixes for bugs you have reported.

      Next update:
      At the moment we’re processing more bugs you have reported and prepare the next bugfix update. If there aren’t any bigger problems thereafter, the next step is the release on Steam.

      Bugtracker status:
      We have improved the bugtracker, it can now import threads from the forum and convert them directly into tickets. For the future it is important that every bug gets its own thread in the forum. At the moment we can’t process collected issues that are in the same topic. At this point we would like to thank you very much for the bug lists from the forum, they have been a very good overview so far. We are still working on a public list and hope to have it online for the Steam release.

      Sample mods:
      Due to the massive changes we had to perform on the vehicles and machines, we had to remove the sample mods for the time being. The work is almost done and we can provide you with the already released machines as ZIP files presumably next week.

      We wish you a pleasant weekend!

      Changelog:

      • NEW: Animal feeding task: employees now can feed the animals

      • NEW: Warning message when a save file is corrupt and cannot be loaded correctly


      • BUG FIX: There has been a problem with the loading of save games that especially occurred with AMD users. It has been fixed
      • BUG FIX: The calculations for traction now only take place on fields. No more slippery roads after rain

      • BUG FIX: Rented vehicles disappear after their length of lease is expired
      • BUG FIX: The plowing mission has been fixed, you can now see the mission progress when you cultivate field 15 (not field 13)

      • BUG FIX: Chopped maize plants don’t grow back at midnight

      • BUG FIX: A tractor doesn’t accelerate any longer when its engine is turned off while driving
      • BUG FIX: After an employee has been tasked with field work and “show” has been pressed in the user interface, the game crashed
      • BUG FIX: One of the traffic trucks has been underpowered and couldn’t manage slopes - that has been adjusted


      • CHANGE: Reworked notification window for missions

      • CHANGE: The user interface shows how many animals/employees/vehicles you can still purchase
      • CHANGE: The volume of audible outdoor sounds in vehicle cabins has been reworked completely and will now be calculated in real time
    • masterbrain wrote:


      • BUG FIX: Chopped maize plants don’t grow back at midnight


      in a new save created with v0.1.0.2, maze stubble still grows back at midnight, likewise after the first planting cycle even if you buy a new field and plant it, that too will grow at midnight.

      the only maze that seams to grow somewhat correctly, is the very first crop you plant on any amount of fields on the first day, which will take about ~60 days to grow, after that any maze stubble or freshly planted maze will all grow at midnight, even if you exit the game and reload the save before time passes midnight.
    • New

      English language. I'll keep trying in missions as well in free play and check the results.

      Edit:
      I did some more testing earlier and I once more made sure that it happens in Missions as well as. The Plants grow for the first time, then when harvesting the stubbles vanish at midnight. As soon as they vanish the workers start to avoid these areas where there was stubble before midnight.

      This leads to some very weird behavior at the end of the field where the worker doesn't seem to register that the harverster reached the end of the field and get's in the way of the it.
    • New

      I believe the problem is twofold.

      A: when saving else loading a savegame, something relating to the field-state is not being saved, else not being loaded.

      B: if you do the welcome to quest that gives you machines, fields and cattle, and if you sell the machines, fields and cattle leaving you with just the money which you then use to buy other fields, you can plant them and it will take ~60 days to grow, you can then harvest it, however after harvesting ANY maze stubble or freshly planted maze will instantly grow at midnight, because one or more quests after ~60 days is expecting maze to be able to be harvested, so at midnight forces any maze be it stubble or freshly planted to a fully grown state on any field including fields that were never part of any quest.

      I can replicate A ad-nauseam by:
      1: create a new profile.
      2: load the Albergtal map.
      3: ignore and close the welcome to Albergtal quest.
      4: buy field 13.
      5: plant maze on field 13.
      6: forward time ~60days and harvest.
      7: after harvesting press F5 to create a savegame (but do NOT exit or load it).
      8: fast forward time to 23:58h then let it move past midnight (stubble will disappear)
      9: create a new savegame using the save as icon in the escape menu, thus creating a second save timed the day after harvesting.
      10: fast forward time again to 23:58h then let it move past midnight (stubble will still not be there, you can repeat this step a few times)
      11: now load the first save you created just after harvesting in step 7.
      12: like in step 8 fast forward time to 23:58h then let it move past midnight, this time the stubble will change into fully grown maze plants.
      13: now load the second savegame, you will see there is no stubble just as you observed when you saved at step 9.
      14: again like in step 10 forward time to 23:58h then let it move past midnight, now observe fully grown maze plants will appear at midnight.

      Now the fact that the loaded savegames cause something different to happen to what we observed before we loaded any savegame would be indicative of some aspect not being save or loaded properly.

      While for B:
      1: create a new profile.
      2: load the Albergtal map.
      3: do the welcome to Albergtal quest, so you get equipment, fields and cattle.
      4: sell everything so you just have money.
      5: buy 2 small fields that you didn’t own when you started and thus are NOT part of any quest.
      6: plant both fields.
      7: forward time ~60days and harvest.
      8: replant 1 field immediately after harvesting while leaving the other as stubble.
      9: fast forward time to 23:58h then let it move past midnight, you will observe that both fields at the turn of midnight became fully grown, which is different behaviour to what we see in A above before loading a savegame.

      Alternatively if you want to show different behaviour for B while also proving A:
      1: create a new profile.
      2: load the Albergtal map.
      3: do all the quests in a single sitting without reloading a save, when you commence the last quest on field 3 you may want to use timeFactor 1 in the console to force real-time.
      4: upon finishing the last quest harvesting field 3, create a save that you can reload in a later step.
      5: fast forward time to 23:58h then let it move past midnight, you will observe the stubble disappear, you can do this a couple of times and the stubble will not be there, likewise the other fields by the farm the small plants will stay as small plants.
      6: now load the save you created in step 4.
      7: fast forward time to 23:58h then let it move past midnight, you will observe ALL the fields now have fully grown maze on them bar the places there are wheel-tracks.


      or in short there is something wrong with the savegame system at the very least as far as field states, and its not an AMD thing, as I am using an Intel X99 platform with an I7-6900k CPU
    • New

      A quick reaction from me. I played around a hour last night. What I noticed is when I brake with the tractor the wheels instantly block and then it looks like you're braking on ice. Also when I turn with the MB Trac and plow the backend will just step out. The gearbox behavior is still weird for me. Manual transmission doesn't work as intended but that will be fixed I guess. Same for that I don't know if pivoting axles are intended for the game? Same for spinning propshafts? And the cat and dog are stuck in one place for me at the farm and sometimes they glitch out and speed off into the grass. For the rest great game :D
      Proper Sim gamer. Rally games tractor and truck games. Bus games and train games you name it :)