Tech-Demo Release v0.0.9.9 - Zum Nikolaus: ein Sack voll Performance

    • Tech-Demo Release v0.0.9.9 - Zum Nikolaus: ein Sack voll Performance

      Passend zum Nikolaus gibt es heute für euch, wie angekündigt, ein Bugfix- und Performance-Update. Enthalten sind unter anderem Änderungen an der KI, Modifikationen beim Interface und einigen Maschinen, z.B. der Sound des Jaguars und der Traktoren und das Fahrverhalten des MB Trac.


      Wir haben zahlreiche Verbesserungen an der Performance vorgenommen und erwarten im Durchschnitt eine Steigerung der Framerate um bis zu 100%. Zum einen haben wir die Anzahl der sichtbaren Objekte auf Distanz stark reduziert (LOD) zum anderen haben wir den Verbrauch des Videospeichers reduziert, indem die Texturen und Schatten optimiert wurden.

      Es gibt jetzt auch ein neues Ultra-Setting für Texturen und eine Warnung, falls die Grafikkarte nicht über genug dedizierten Videospeicher verfügt. Für das Ultra Setting sollte man eine Grafikkarte mit mindestens 3 GB VRAM haben.

      Besonders wichtig ist noch zu erwähnen, dass es unter Windows 7 starke Performanceprobleme mit dem Aero Theme Manager gab. Dieser wird jetzt von unserem Spiel temporär ausgeschaltet was zu einer Verdopplung der Framerate führen kann.

      Weitere Änderungen, Bugfixes und Neuerungen könnt ihr wie immer der Changelog entnehmen.

      Das MBB-Team wünscht euch einen schönen Nikolaus!



      Changelog:


      • LAUNCHER UPDATE: Der Launcher wurde auf die Version 0.4.6 aktualisiert und ist jetzt in der Lage, veraltete Dateien, die nicht mehr vom Spiel benötigt werden, zu löschen


      • NEU: Differentialsperre: alle Fahrzeuge verfügen jetzt über ein gesperrtes Differential und kommen so im Gelände besser zurecht

      • NEU: Man erhält eine Warnung In den Grafikoptionen, falls nicht genug Videospeicher für die gewünschte Texturqualität vorhanden ist


      • BUG FIX: Der KI-Navigator wurde überarbeitet, dadurch fährt der KI-Verkehr nicht mehr quer über die Felder

      • BUG FIX: Performanceprobleme bei aktiviertem Missions-Marker wurden behoben

      • BUG FIX: Im Trading-Window kann man nun direkt über den Startknopf die Aktion ausführen, zuvor musste man erste eine Lademenge auswählen

      • BUG FIX: Der Jaguar neigt sich während des Bremsens nicht mehr nach vorne

      • BUG FIX: Der Jaguar wirft kein Häckselgut mehr aus wenn er angelassen wird

      • BUG FIX: Probleme mit der Höhe von angehängten Anbaugeräten am Hof wurden behoben

      • BUG FIX: Man kann mit dem Arion wieder pflügen


      • ÄNDERUNG: Ein LOD-System für Fahrzeuge wurde eingeführt. Damit werden einige Elemente auf Distanz ausgeblendet, dies führt zu einer erheblichen Verbesserung bei vielen gleichzeitig sichtbaren Fahrzeugen

      • ÄNDERUNG: Der VRam-Verbrauch wurde stark reduziert. Texturen verbrauchen auf Maximalem Level 2.62GB anstatt 3.57GB

      • ÄNDERUNG: Unter Windows 7 wird “Aero” nun ausgeschaltet, wenn das Spiel gestartet wird, dies sorgt für eine höhere Framerate
      • ÄNDERUNG: Es wurde eine zusätzliche Textur-Qualitätsstufe eingebaut, es gibt jetzt Gering, Mittel, Hoch und Ultra

      • ÄNDERUNG: Das Fahrverhalten aller Fahrzeuge wurde überarbeitet. Neue Getriebe-, Motor- und Physik-Einstellungen sorgen für ein realistischeres Fahrgefühl

      • ÄNDERUNG: Der Motorsound des Jaguar wurde überarbeitet

      • ÄNDERUNG: Die Motorsounds des Arion und Axion wurden überarbeitet

      • ÄNDERUNG: Die Abfahrer blockieren nicht mehr die Feldeinfahrten, sie suchen sich jetzt eine Parkposition am Straßenrand, ohne den Häcksler bei der Fahrt zum Feld zu behindern

      • ÄNDERUNG: Die Reload- und Respawn-Buttons in der Fuhrpark-Ansicht wurden wieder implementiert

      • ÄNDERUNG: Einige Schritte in den Missionen können jetzt übersprungen werden. Zusätzlich gibt es ein Cheat/Konsolen-Kommando “skipCondition” um laufende Missions-Schritte zu überspringen

      • ÄNDERUNG: Die Season-One-Mission wurde überarbeitet
    • Wow!

      Das ist mal eine laaaange Liste Verbesserungen! :D
      Naja, ich lade noch am zweiten update. Nach dem ersten, hatte mein Launcher das erste mal ein Bild.
      Zwar immer noch nicht richtig, aber ein Bild! :thumbup:
      System
      Display Spoiler

      Desktop
      CoolerMaster HAF-X I CoolerMaster 1000W RS-A00-ESBA Netzteil I
      I7 3930K normal getaktet (nur bei "Bedarf" 4,2Ghz@ standart Vcore)
      Asus x79 Sabertooth I G-Skill Ares 1866 Ram 2x8Gb I Zotac 1070 mini I
      500GB Samsung 960 EVO M.2 auf DeLockadapter I 3x2TB Raid5
      CPU Wassergekühlt (selbst zusammengestellte Kühlung)

      Laptop:
      I7 6700HQ I GTX1070 I 17,3" FullHD I 16GB DDR4 I 512GB M.2SSD
      Kühlpad
    • Ich muss gestehen da hat sich echt etwas getan.
      Mit meiner AMD Karte komme ich zwar nur auf "niedrig" an eine vernünftige FPS Anzahl aber immerhin ist es damit wirklich spielbar.
      Hoffe da tut sich bis zur V1.0 auch noch auf höheren Einstellungen etwas. Will ja nicht, dass sich die 2GB VRAM langweilen :D

      Ihr macht echt ne tollle Arbeit MBB.
      Es ist eben noch kein Game von heute auf morgen fertig geworden.

      Weiter so dann wird das schon.
    • Hallo,

      Performance ist jetzt super !
      Standardmaßig habe ich 60 fps. Beim Mais Häckseln zwischen 30 - 40 fps. Mit dem Helfer hat das richtig Spaß gemacht :thumbsup:

      Mir ist aufgefallen:

      - Die Glasscheibe im Jaguar bei Nacht ist sehr trübe. Hier sollte nachgebessert werden
      - Die Maisstoppeln sind nach dem Häckseln teilweise weg
      - Die Beladeanimation im Anhänger ist noch nicht optimal
      - Der Helfer lenkt bei gerader Fahrt immer nach rechts und links
      - Der Tag ist sehr überstrahlt

      Ansonsten macht des Spiel echt gute Fortschritte
    • Die Fahrzeugphysik ist jetzt super! Ihr müsst mal das Fass an den 940 anhängen und dann losfahren und bremsen, das sieht absolut Geil aus!

      Auch der Jaguar neigt sich jetzt korrekt, super!

      Nur das Fass und die Sämaschine haben jetzt eine falsche Seitenneigung bei etwas schneller Kurvenfahrt!
      Die Spritze scheint keine Neigungsfunktion bekommen zu haben? Zumindest ist diese nur sehr schwach ausgeprägt.
      Der Hächselwagen funktioniert allerdings super, sieht richt gut aus!

      Der Traktorensound ist jetzt schon besser, lange nicht mehr so nerfig wie vorher, nur der Vollgassound wiederholt sich zu oft.


      Wenn ich beim Axion die Scheinwerfer anschalte, dann wird bei mir auch einiges in Grau dargestellt bei Abblendlicht ist alles gut.
      Zu hoch sind die Scheinwerfer auch eingestellt.

      Was die Performance angeht, kann ich leider keine große Verbesserung feststellen, meine Vega dümpelt bei Einstellung Mittel immer noch bei 30-50 FPS rum. Einstellung Hoch.

      Aber alles in Allem, ein wirklich schönes Update! Danke! Ach ja, der KI Verkehr braucht noch Sound.
      Images
      • mittel.jpg

        534.55 kB, 2,560×1,440, viewed 117 times
      • hoch.jpg

        546.24 kB, 2,560×1,440, viewed 117 times
      Vote for Vulkan Support in CaC!
      i7 3770K, 8GB 1600Mhz, AMD RX Vega 56 <-- alles unter Wasser an BenQ XL2730Z(1440p@144Hz)..... Windows 10 64bit

      Der Ursprung aller Macht ist das Wort.

      The post was edited 11 times, last by DannyA4 ().

    • guten Abend

      Ein riesen großes Dankeschön ans ganze MBB Team für dieses großartige Nikolausgeschenk <3 :thumbsup:

      mfG:Sebastian
      System
      Display Spoiler
      CPU: Intel Core I5 8400 6x 2.8Ghz bis 4.0Ghz
      MoBa: Asus Prime Z370-P
      GPU: Zotac GeForce GTX 1080 Mini (398.18)
      RAM: Crucial 16GB DDR4 2666 Mhz
      SSD: Kingston SSDNow UV400 240GB
      HDD: Toshiba 2TB 7200RPM 64MB Cache
      PSU: BeQuiet Straight Power 10 500W CM
      OS: Windows 10 (1803) Home 64bit

    • @DannyA4

      Kontrollier nochmal das Bremsverhalten Claas und Fass.
      Ich meine irgendwie stimmt da was nicht, sollte das Fass nicht beim Bremsen in die Kupplung drücken?
      Und Schlepper hinten entgegen der normalen Bewegung runter drücken?

      Das Fass scheint aber irgendwie nicht zu schieben.
      Geht entgegen meiner Erwartung hinten runter und vorne hoch.
      Die Gülle sollte aber andersrum drücken, oder bin ich da auf dem Holzweg?

      Nachtrag: Mich hat ein Fehler beim Häckseln raus gehauen, wie bei 0.0.9.8. ;(
      Da war es aber andere Stelle. Jetzt war Anhänger scheinbar voll, vom Abfahrer.
      Leider keine Anzeige (100%). Als ich dann Abfahrer wegschickte, flog ich mit dem Wegschickklick
      gleich raus mit Bugtracker.
      System
      Display Spoiler

      Desktop
      CoolerMaster HAF-X I CoolerMaster 1000W RS-A00-ESBA Netzteil I
      I7 3930K normal getaktet (nur bei "Bedarf" 4,2Ghz@ standart Vcore)
      Asus x79 Sabertooth I G-Skill Ares 1866 Ram 2x8Gb I Zotac 1070 mini I
      500GB Samsung 960 EVO M.2 auf DeLockadapter I 3x2TB Raid5
      CPU Wassergekühlt (selbst zusammengestellte Kühlung)

      Laptop:
      I7 6700HQ I GTX1070 I 17,3" FullHD I 16GB DDR4 I 512GB M.2SSD
      Kühlpad
    • Ich denke nicht, stelle dir vor, dass das Fass mitbremst.
      Ich habe die Situation jetzt nur mit leerem Fass probiert, mit vollem Fass sollte es so sein wie du es beschrieben hast.

      Bin da aber auch bloß Laie! :whistling:

      Edit:

      nochmal drüber nachgedacht, ich glaube du hast Recht!
      Bisschen komisch sieht das schon aus!
      Vielleicht ist das ja auch einfach alles verdreht, die seitlichen Bewegungen sind ja auch vertauscht.
      Vote for Vulkan Support in CaC!
      i7 3770K, 8GB 1600Mhz, AMD RX Vega 56 <-- alles unter Wasser an BenQ XL2730Z(1440p@144Hz)..... Windows 10 64bit

      Der Ursprung aller Macht ist das Wort.

      The post was edited 1 time, last by DannyA4 ().

    • @DannyA4

      Das war es ja, war auch am zweifeln. Aber hatte Fass gut halb voll und selbst wenn das Fass bremst, die Ladung hat ja keine Bremse. ^^
      Aber, das ist wohl definitiv eine Frage an unsere Profi's, die könne da eher eine realistische Einschätzung bieten.

      Hab noch paar Sachen, die nicht passen, muss mal meine Screenshot`s kontrollieren.

      Leider konnte ich in vor Version wie in dieser keine Saison durchtesten. ;(
      System
      Display Spoiler

      Desktop
      CoolerMaster HAF-X I CoolerMaster 1000W RS-A00-ESBA Netzteil I
      I7 3930K normal getaktet (nur bei "Bedarf" 4,2Ghz@ standart Vcore)
      Asus x79 Sabertooth I G-Skill Ares 1866 Ram 2x8Gb I Zotac 1070 mini I
      500GB Samsung 960 EVO M.2 auf DeLockadapter I 3x2TB Raid5
      CPU Wassergekühlt (selbst zusammengestellte Kühlung)

      Laptop:
      I7 6700HQ I GTX1070 I 17,3" FullHD I 16GB DDR4 I 512GB M.2SSD
      Kühlpad
    • Hallo,also die Perfomance hat sich aufjedenfall verbessert,habe jetzt 60 FPS auf Einstellungen Hoch.Mir ist aber aufgefallen wenn ich über das Feld fahre,und habe die Partikel an von der Saatmaschiene,läuft es ein wenig holprig,wenn ich die partikel ausgeschaltet habe in den Optionen von der Saatmaschiene läuft es wie Butter.Fressen die Partikel soviel CPU? Ansonsten bin ich sehr zufrieden mit dem Update :-).Der Helfer arbeitet auch schonmal besser,also beim ersten Ernten hat alles so funktioniert wie es sein sollte.Bei dem zweiten Feld ging das wieder los,das er nicht hinterher oder nebenher mit fahren wollte,er blieb stur am Feldrand stehen.Als ich dann ohne Helfer einfach den Mais Häckseln wollte,das alte Problem wieder,er hat kein Mais gehäckselt.Aber ansonsten bin ich zufrieden,das wird schon noch alles :)
    • Und beim pflügen habe ich erheblich mehr CPU last, als bei anderen Arbeiten.
      Als ich in der Mission das Feld pflügte gab es massive unterschiede, ob ich in Richtung des Tierhandel oder davon weg arbeitete.
      Davon weg, war der Prozessorbalken fast voll.
      Und das bei meinem Prozessor!?!
      System
      Display Spoiler

      Desktop
      CoolerMaster HAF-X I CoolerMaster 1000W RS-A00-ESBA Netzteil I
      I7 3930K normal getaktet (nur bei "Bedarf" 4,2Ghz@ standart Vcore)
      Asus x79 Sabertooth I G-Skill Ares 1866 Ram 2x8Gb I Zotac 1070 mini I
      500GB Samsung 960 EVO M.2 auf DeLockadapter I 3x2TB Raid5
      CPU Wassergekühlt (selbst zusammengestellte Kühlung)

      Laptop:
      I7 6700HQ I GTX1070 I 17,3" FullHD I 16GB DDR4 I 512GB M.2SSD
      Kühlpad
    • Theoretisch könnteste recht haben, aber bei Blickwinkel von oben auf den Schlepper und Grund.
      Stark eingegrenztes Sichtfeld, damit ich in Pflugfurche bleibe, sollte das nicht so schlimm sein, oder irre ich mich?

      Feld 4 mit Grubber habe ich erheblich weniger Last und gut 30% mehr FPS.

      Vielleicht kann ja einmal jemand nachtesten?
      Ob bei Ihm beim pflügen Feld 5 oder 6 (?) am Tierhändler auch die Last extrem hoch geht und FPS im Keller.

      Evtl 4K Problem in Verbindung der Bodenveränderung (Tessalation etc)
      Bringt das evtl gerade beim Pflug mehr Last auf CPU als beim grubbern?


      Ich muss gaaaanz dringend mal auf Lappi gegen testen, wenn ich mal zu kommen würde.
      Da auch GTX 1070, nur eben auf 1080P nicht 4K. Dann kann ich das vielleicht rausbekommen.
      System
      Display Spoiler

      Desktop
      CoolerMaster HAF-X I CoolerMaster 1000W RS-A00-ESBA Netzteil I
      I7 3930K normal getaktet (nur bei "Bedarf" 4,2Ghz@ standart Vcore)
      Asus x79 Sabertooth I G-Skill Ares 1866 Ram 2x8Gb I Zotac 1070 mini I
      500GB Samsung 960 EVO M.2 auf DeLockadapter I 3x2TB Raid5
      CPU Wassergekühlt (selbst zusammengestellte Kühlung)

      Laptop:
      I7 6700HQ I GTX1070 I 17,3" FullHD I 16GB DDR4 I 512GB M.2SSD
      Kühlpad
    • Liebes Masterbrain Team

      Ich habe mich die ganze zeit, aus den Diskussionen raus gehalten warum ist das Spiel noch nicht fertig schon wieder die Erscheinung verschoben wurde.
      Ich dachte mir die ganze Zeit lass die Leute arbeiten die schaffen das schon und mit diesem Update was Ihr jetzt raus gebracht habt habt ihr euch meilenweit übertroffen.

      Für mich war die ganze Zeit das spielen der TechDemo nicht wirklich ein Spaß da das Spiel wirklich Stark Geruckelt hat obwohl ich einen guten Rechner habe

      Aber seit dem jetzigen Update läuft das Spiel konstant 60 FPS läuft wie ein geschmierter Motor.

      Danke für die klasse Arbeit

      Euer Chrio
    • Danke für das Nikolausgeschenk! ;)

      DIE Performance ist wirklich besser geworden, die +100% kommen hin! Es ist jetzt spielbar auch mit allen bisherigen Fahrzeugen zusammen. Natürlich könnte es noch ein bisschen besser werden, aber ich denke bis zur 1.0 wird man schon noch die ein oder andere Stellschraube finden, aber man kann zumindest schon ohne große Ruckler spielen!

      Bei mir hats vorhin mehrmals beim Launcher rumgesponnen, musste mehrmals Login eingeben und danach war Server nicht zu erreichen, nach paar mal neustarten gings dann. Dann später nochmal spielen wollen wieder das gleiche. Hatte das heute auch jemand? Oder nur beim mir?
    • Hallo,
      möchte hier ja nicht die Spaßbremse sein, aber leider ist das von mir vor einiger Zeit geschilderte Problem nach wie vor vorhanden:
      Mir ist es nicht möglich mit einem Claas Arion 940 den Lemken Pflug anzuheben. Zudem wackelt u. zittert der Pflug ganz übel.
      Betrifft nur die Kombination Arion940 u. Lemken Pflug!

      Ulli
      Windows 10 Pro, 64-bit
      Intel(R) Core(TM) i7 - 6700K CPU
      4.00 GHz 4.00 GHz
      16,0 GB RAM
      GeForce GTX 1070
    • Hast du mal alles deinstalliert, DANN den CaC Ordner unter "Programme " und dann den CaC Ordner unter Dokumente gelöscht?
      Dann mal den Launcher neu runterladen und den ganzen Quark neu installiert?
      Vote for Vulkan Support in CaC!
      i7 3770K, 8GB 1600Mhz, AMD RX Vega 56 <-- alles unter Wasser an BenQ XL2730Z(1440p@144Hz)..... Windows 10 64bit

      Der Ursprung aller Macht ist das Wort.
    • Nachdem ich die letzten Updates pausiert hatte, hab ich dieses mal wieder ausprobiert und muss sagen, es läuft fast alles super! Von mir aus kann es also mit EA losgehen ;)
      Ein paar Sachen würde ich mir noch wünschen, z.B. ne Anzeige, in welchem Gang man gerade fährt, in der Fahrzeug-Außenansicht, aber sonst bin ich schon sehr angetan
    • tgs_wort wrote:

      @DannyA4

      Kontrollier nochmal das Bremsverhalten Claas und Fass.
      Ich meine irgendwie stimmt da was nicht, sollte das Fass nicht beim Bremsen in die Kupplung drücken?
      Und Schlepper hinten entgegen der normalen Bewegung runter drücken?

      Das Fass scheint aber irgendwie nicht zu schieben.
      Geht entgegen meiner Erwartung hinten runter und vorne hoch.
      Die Gülle sollte aber andersrum drücken, oder bin ich da auf dem Holzweg?
      huhu,

      bei Luftdruckgebremsten Gespannen sollte (bei korrekt eingestellter Luftdruckbremse) Der Anhänger immer eher und stärker bremsen als dass Zugfahrzeug.

      Sprich der Anhänger bremst deutlich das gesammte Gespann. So sollte er normal nicht in das Zugmaul "knallen"

      Bei Auflaufgebremsten Anhängern ist das natürlich genau andersrum... die knallen erst ins Zugmaul und bremsen dann :)


      Thema Gülle. Klar ist die in Bewegung, aber in den modernen Fässern sind auch Schwallwände eingearbeitet, die das starke hin und her schaukeln verhindern.
    • Servus :)
      Leider auch dieses mall keinen Daumen nach oben. :(
      Missionen sind nach der Aufgabe Dünge die erste bahn (Feld 11)abgebrochen,es ging nicht weiter. :(
      Grubber ging dieses mall halbwegs,mit Zappeln und Zittern,aber schlechter wie vor hehr.Warum auch immer. :(
      Pflügen ist eine reine Katastrophe,der Traktor hat 136 PS,aber da fehle Woll 100 Pferdchen. :(
      (Mit einem Ochsengespann werde ich besser dran gewesen.)Und beim pflügen die CPU mehr last,die GK jaulte wie einen Schakal. :(
      Vor allem wo ist die Leistung von den Traktoren geblieben? Sie sind wie eine Schnecke unterwegs,egal ob auf dem Feld oder auf der Strasse. :(
      Abgesehen davon das Ihr viel Zeit inverstirt habt,wahr auch dieses Update nicht so gut. :( Das ganze Testen wahr sehr Anschtrengend und mann kam nur mühesam voran. :(
      Leider ist noch viel Arbeit nötig biss das mal richtig läuft,Bitte last euch Zeit,macht das richtig und nicht ein Halbfertiges Produkt auf den Mart stellen.

      PS:Alles wie immer neu gemacht, die alte Version gelöscht und so eine Auslastung von CPU und GK noch nicht gehabt. :(
      (Zum Vergleich,ich habe schon andere Spiele auf meinem Rechner gehabt und mit höchste Einstellung sind sie besser gelaufen wie die letzte Version
      v0.0.9.9 in Mittlere Einstellung.Auch die FPS gehen von 58.5 bis 29.5 hin und hehr.Ich habe keinen Plan. ?(
      ES GIBT NOCH VIEL ZU TUEN:MACHT WEITER. :thumbsup:
      Mfg :)
    • @Fritz55

      Das mit der Trecker Leistung/Geschwindigkeit, hatte ich auch bemerkt.
      Durch update hat sich das Spiel wohl verstellt, so konnt man zwar "Gastaste" drücken, was aber nur Halbgas ist.
      Erst mit Umschalttaste gibt er Gas! Oder Häkchen an immer Vollgas benutzen.

      Das mit der CPU Last (pflügen) hatte ich auch, was echt Hammer ist.
      Bis jetzt läuft mein Prozessor "nur" Asus optimiert im Bios, werde wohl für C&C ein Übertaktungsprofilanlegen.
      ---------------------------
      @StrAmMberG

      Danke! Also drückt so ein Fass oder luftdruckgebremster Anhänger nicht die Deischel runter?
      System
      Display Spoiler

      Desktop
      CoolerMaster HAF-X I CoolerMaster 1000W RS-A00-ESBA Netzteil I
      I7 3930K normal getaktet (nur bei "Bedarf" 4,2Ghz@ standart Vcore)
      Asus x79 Sabertooth I G-Skill Ares 1866 Ram 2x8Gb I Zotac 1070 mini I
      500GB Samsung 960 EVO M.2 auf DeLockadapter I 3x2TB Raid5
      CPU Wassergekühlt (selbst zusammengestellte Kühlung)

      Laptop:
      I7 6700HQ I GTX1070 I 17,3" FullHD I 16GB DDR4 I 512GB M.2SSD
      Kühlpad

      The post was edited 1 time, last by tgs_wort ().